[go: nahoru, domu]

Update some 'compositor' prefix in mutator related APIs to 'worklet'

There are some APIs like CompositorMutatorImpl, CompositorAnimator that
are out of date due to the recent change which introduced mutating
animations via the main thread.

In addition, using |Animator| was an unfortunate mistake since we have
an animator concept elsewhere (an in the spec) that is different.

Proposed changes:
CompositorMutator -> AnimationWorkletMutatorDispatcher
WorkletMutatorImpl -> AnimationWorkletMutatorDispatcherImpl
CompositorAnimator -> AnimationWorkletMutator
CompositorMutatorInput[Output]State -> AnimtionWorkletDispatcherInput[Output]

Bug: 839341, 883922
Cq-Include-Trybots: luci.chromium.try:android_optional_gpu_tests_rel;luci.chromium.try:linux_layout_tests_slimming_paint_v2;master.tryserver.blink:linux_trusty_blink_rel
Change-Id: Ic97a125d021ec2a62174d897c9bf67b522130881
Reviewed-on: https://chromium-review.googlesource.com/1224494
Commit-Queue: Yi Gu <yigu@chromium.org>
Reviewed-by: Stephen McGruer <smcgruer@chromium.org>
Reviewed-by: Jeremy Roman <jbroman@chromium.org>
Reviewed-by: Majid Valipour <majidvp@chromium.org>
Cr-Commit-Position: refs/heads/master@{#591573}
41 files changed