[go: nahoru, domu]

There was confusion in the mock socket classes due to
overlapping names.  The MockSocket is not actually a socket.
It is an interface for fetching data for reads and writes
on a socket.  The MockClientSocket and MockTCPClientSocket
are the actual sockets.

Rename MockSocket to SocketDataProvider.
Rename SSLMockSocket to SSLSocketDataProvider.

Update all tests to reflect name change.

BUG=none
TEST=none

Review URL: http://codereview.chromium.org/384024

git-svn-id: svn://svn.chromium.org/chrome/trunk/src@31640 0039d316-1c4b-4281-b951-d872f2087c98
10 files changed