[go: nahoru, domu]

History log of /drivers/spi/spi-dw.h
Revision Date Author Comments
15ee3be78b017ee9d697fe59d45cdfbb35d9fdeb 02-Oct-2014 Andy Shevchenko <andriy.shevchenko@linux.intel.com> spi: dw-mid: change magic numbers to the constants

Instead of using magic numbers in the code we create a bit map definition of
the DMACR register and use it.

There is no functional change.

Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Signed-off-by: Mark Brown <broonie@kernel.org>
b89e9c87dd3b118f0b953d349e5bede1505e3bc5 12-Sep-2014 Andy Shevchenko <andriy.shevchenko@linux.intel.com> spi: dw-mid: remove redundant dmac member

Instead of using that member we prefer to use dma_dev which represents actual
struct device of the DMA device.

Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Signed-off-by: Mark Brown <broonie@kernel.org>
05ed2aee3e97c9cfb737388706b439264e27eb0c 12-Sep-2014 Andy Shevchenko <andriy.shevchenko@linux.intel.com> spi: dw: remove FSF address

There is no need to keep FSF address in the head of the file. While here, fix
few typos in the header.

There is no functional change.

Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Signed-off-by: Mark Brown <broonie@kernel.org>
d9c73bb8a3a5e4b76d2ad55da00d9ea776475c81 30-Jan-2014 Baruch Siach <baruch@tkos.co.il> spi: dw: add support for gpio controlled chip select

Also, use this opportunity to let spi_chip_sel() handle chip-select
deactivation as well.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Mark Brown <broonie@linaro.org>
ec37e8e1f0e376776dde5e9539af414d2ec31f71 30-Jan-2014 Baruch Siach <baruch@tkos.co.il> spi: dw: migrate to generic queue infrastructure

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Mark Brown <broonie@linaro.org>
04f421e7b0b10de3fae543dac4d324b449a1db6b 30-Dec-2013 Baruch Siach <baruch@tkos.co.il> spi: dw: use managed resources

Migrate mmio code and core driver to managed resources to reduce boilerplate
error handling code. Also, handle clk_enable() failure while at it, and drop
unused dw_spi iolen field.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Mark Brown <broonie@linaro.org>
0a47d3c40428fb8174ea36ede35267ddc7042f34 26-Dec-2013 Baruch Siach <baruch@tkos.co.il> spi: dw: drop unused struct dw_spi field

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Mark Brown <broonie@linaro.org>
7eb187b3cd3f6f285d91a196dbefac9b6adbb07c 20-Sep-2011 H Hartley Sweeten <hartleys@visionengravers.com> spi: spi-dw: fix all sparse warnings

The dw_{read,write}[lw] macros produce sparse warnings everytime they
are used. The "read" ones cause:

warning: cast removes address space of expression
warning: incorrect type in argument 1 (different address spaces)
expected void const volatile [noderef] <asn:2>*addr
got unsigned int *<noident>

And the "write" ones:

warning: cast removes address space of expression
warning: incorrect type in argument 2 (different address spaces)
expected void volatile [noderef] <asn:2>*addr
got unsigned int *<noident>

Fix this by removing struct dw_spi_reg and converting all the register
offsets to #defines. Then convert the macros into inlined functions so
that proper type checking can occur.

While here, also fix the three sparse warnings in spi-dw-mid.c due to
the return value of ioremap_nocache being stored in a u32 * not a
void __iomem *.

With these changes the spi-dw* files all build with no sparse warnings.

Signed-off-by: H Hartley Sweeten <hsweeten@visionengravers.com>
Acked-by: Feng Tang <feng.tang@intel.com>
Signed-off-by: Grant Likely <grant.likely@secretlab.ca>
40bfff85ffb5c85ffabcb6d71e64f70799595f89 08-Jul-2011 Liu, ShuoX <shuox.liu@intel.com> spi/dw: Add spi number into spi irq desc

Signed-off-by: ShuoX Liu <shuox.liu@intel.com>
Signed-off-by: Grant Likely <grant.likely@secretlab.ca>
ca632f556697d45d67ed5cada7cedf3ddfe0db4b 06-Jun-2011 Grant Likely <grant.likely@secretlab.ca> spi: reorganize drivers

Sort the SPI makefile and enforce the naming convention spi_*.c for
spi drivers.

This change also rolls the contents of atmel_spi.h into the .c file
since there is only one user of that particular include file.

v2: - Use 'spi-' prefix instead of 'spi_' to match what seems to be
be the predominant pattern for subsystem prefixes.
- Clean up filenames in Kconfig and header comment blocks

Signed-off-by: Grant Likely <grant.likely@secretlab.ca>
Acked-by: Wolfram Sang <w.sang@pengutronix.de>
Acked-by: Linus Walleij <linus.walleij@linaro.org>